Inter-Net.PRO

Kunena Discuss - проблемы

  • 19 7
23 апр 2018 19:58 #1 от Люба
Здравствуйте. Темы на форуме создаются, но после добавления комментария недоступна страница с материалом, т.е просто белый экран. Обновление страницы, очистка кэша и тд не помогают. Страница становится доступной только после удаления темы на форуме.

  • 216 50
23 апр 2018 22:41 #2 от Inter-Net PRO
Inter-Net PRO ответил в теме "Kunena Discuss - проблемы"
Я вынес в отдельную ветку проблему.

Эх если бы вы раньше на пару месяцев обратились - я так припоминаю что то подобное у меня было при настройках этого плагина. Я уже забыл что именно создавало конфликт.
Скорее всего, это ошибка в настройках. Я сейчас у себя посмотрю что тут за настройки.
Спасибо сказали: Люба

  • 216 50
23 апр 2018 22:47 #3 от Inter-Net PRO
Inter-Net PRO ответил в теме "Kunena Discuss - проблемы"
По моему в этих настройках вся проблема и наверное здесь у вас неправильно:
Вложения:
Спасибо сказали: Люба

  • 19 7
24 апр 2018 01:06 - 24 апр 2018 09:57 #4 от Люба
Люба ответил в теме "Kunena Discuss - проблемы"
У меня, к сожалению (почему-то) все на английском. в строке Topic Owner я верно указала свой ID?
..и еще: когда включаю плагин в топе сайта иконки

становятся такими )))

Так же меняется иконка часов (где указывается дата создания материала). Шаблон shaper kidzy (кикстарт)
Вложения:

  • 216 50
24 апр 2018 10:05 #5 от Inter-Net PRO
Inter-Net PRO ответил в теме "Kunena Discuss - проблемы"
Я вам положил файл русификации для Kunena Discuss.
Архив без установочника - нужно в ручную добавлять.
Скачайте и распакуйте архив у себя на компьютере. Файл из архива залейте на сайт по пути:
administrator\language\ru-RU\
Вложения:
Спасибо сказали: Люба

  • 216 50
24 апр 2018 10:15 #6 от Inter-Net PRO
Inter-Net PRO ответил в теме "Kunena Discuss - проблемы"

Люба пишет: в строке Topic Owner я верно указала свой ID?

Да, в это поле указывается ID пользователя от имени которого будет создаваться тема на форуме (топик стартер).
Здесь можете указать как свой ID так и любого из пользователей. Например, можно создать пользователя с именем "Система" или с названием сайта и на его ID повесить топик-старт.
Спасибо сказали: Люба

  • 216 50
24 апр 2018 10:38 #7 от Inter-Net PRO
Inter-Net PRO ответил в теме "Kunena Discuss - проблемы"

Люба пишет: когда включаю плагин в топе сайта иконки
Шаблон shaper kidzy (кикстарт)

Это новые иконки из FontAwesome 5. Там такая хитрость, что если класс иконки прописан неправильно, то вместо предполагаемой иконки выводится такой вопросик как у вас на скрине.
Сейчас в Кунене пока ещё прописаны вот такие иконки из FontAwesome 4.7.0 .
Очень скоро выйдет Кунена 5.1 и там уже классы иконок полностью исправлены под версию FontAwesome 5.x

Я не знаю, может вы сами подключили у себя FontAwesome 5 к сайту? Включите пока FontAwesome 4.7.0
Или это из вашего куненовского шаблона подключается FontAwesome 5???
Спасибо сказали: Люба

  • 19 7
24 апр 2018 11:05 #8 от Люба
Люба ответил в теме "Kunena Discuss - проблемы"
Здравствуйте. FontAwesome отключила- иконки в порядке))), с русским языком так же все хорошо, но вот экран, паразит. все-равно белый пока тема существует на форуме

  • 216 50
24 апр 2018 14:15 #9 от Inter-Net PRO
Inter-Net PRO ответил в теме "Kunena Discuss - проблемы"
Белый экран материала или экран темы на форуме?

Обычно если нет сообщения об ошибке, то сначала включают дефолтные шаблоны джумлы (Protostar) и кунены (Cripsis).
Зачастую проблемы бывают из за модулей. Чтобы проверить - вырубить все модули выводимые на белой странице.

  • 19 7
24 апр 2018 14:32 #10 от Люба
Люба ответил в теме "Kunena Discuss - проблемы"
шаблоны Кунена меняла. сейчас буду пробовать с джумла

  • 216 50
24 апр 2018 14:45 - 24 апр 2018 14:45 #11 от Inter-Net PRO
Inter-Net PRO ответил в теме "Kunena Discuss - проблемы"
Так а белая страница где, на форуме или на материале???

  • 19 7
24 апр 2018 14:57 #12 от Люба
Люба ответил в теме "Kunena Discuss - проблемы"
пункту меню с материалом назначала шаблон Protostar, кунене- Crypsis. Пока есть тема на форуме- белая страница материала (((. Модули отключала все полностью

  • 216 50
24 апр 2018 15:27 - 24 апр 2018 15:33 #13 от Inter-Net PRO
Inter-Net PRO ответил в теме "Kunena Discuss - проблемы"
Если в материале, то шаблон форума можно не трогать.
А вот когда в материале с вырубленными модулями да ещё и на протостаре, тогда хреново - похоже из за плагина косяк.
У вас наверно версия последняя - недавно обновлённая?
Я у себя ещё не обновлял дискусс, но может с неделю назад смотрел гитхаб куненовский - вроде там как апи под кунену 5,1 подогнали в этом плагине.
У меня кстати на тестовом сайте где стоит кунена 5.1 - дискусс даёт белую страницу. Я там кстати тоже дискусс ещё не обновлял. Нужно на гитхабе найти и посмотреть что они там в коде наизменяли.

Или как вариант, посмотреть ещё буржуйский оф форум кунены, может там уже были предъявы что они плагин закосячили и есть рецептик. Или попробуйте написать им там: что это за беспредел, почему не работает?
Спасибо сказали: Люба

  • 19 7
24 апр 2018 15:37 #14 от Люба
Люба ответил в теме "Kunena Discuss - проблемы"
я позавчера только скачала плагин..plg_content_kunenadiscuss_v5.0.4_2018-04-12- это самый новый? Где взять предшественника? может попробовать более раннюю версию поставить?

  • 216 50
24 апр 2018 17:47 #15 от Inter-Net PRO
Inter-Net PRO ответил в теме "Kunena Discuss - проблемы"
Я скопировал и упаковал дискусс который у меня стоит на этом сайте .
Можете попробовать установить. Если стандартной установкой не станет, то распаковать и вручную залить по пути:
plugins/content/kunenadiscuss

Может реально в версии проблема. Я пока на гитхаб не лазил и не проверял по поводу этого плагина.
Вложения:
Спасибо сказали: Люба

  • 19 7
24 апр 2018 19:46 #16 от Люба
Люба ответил в теме "Kunena Discuss - проблемы"
:silly: не прошел номер..Буржуинам написала-если поймут, может и ответят ))

  • 19 7
24 апр 2018 19:53 #17 от Люба
Люба ответил в теме "Kunena Discuss - проблемы"
Экспериментально попробую сегодня на локальном (есть копия) поставить кунену 5,0,13 и ваш zip, а после обновлюсь. Если получится- отпишусь

  • 19 7
25 апр 2018 19:36 #18 от Люба
Люба ответил в теме "Kunena Discuss - проблемы"
Ничего не получилось (((, все по-прежнему. Буржуи не отвечают (может просто не поняли, что я им напереводила гуглом:P )
А я до того наковыряла на сайте, что теперь иконки исчезли . Не мое это...
Вложения:

  • 216 50
25 апр 2018 20:24 #19 от Inter-Net PRO
Inter-Net PRO ответил в теме "Kunena Discuss - проблемы"
Только ковыряясь можно что то понять.
Я тоже пару лет назад что то очень сильно захотел поменять. На протяжении года ковырял эту кунену пока нашёл решение. А теперь даже не помню что именно хотел поменять, так как расчехлил в чём фишка и сменил очень многое.

Вы смотрите, на любом нормальном хостинге должно быть "Резервное копирование". Это когда хостинг сам на автомате делает копию сайта и Базы Данных. У меня например, хостинг делает копии каждую ночь и сохраняет копии за последние 7-дней и 1-ну копию 30-ти дневной давности.
Так вот можно сайт откатить из панели хостинга до состояния в нужный день (например на три дня назад). Тем самым, если конкретно что то закосячили, можем сайт и БД откатить до нужного дня без переустановки сайта.

Тема резервного копирования очень популярна. Все косячат и активно откатывают.
Бывало и такое что целый день туда-сюда откатил-закосячил.
Спасибо сказали: Люба

  • 19 7
28 апр 2018 13:18 #20 от Люба
Люба ответил в теме "Kunena Discuss - проблемы"
Спасибо, помогло :P. Но все- равно временами себя круглой дурой чувствую. А бекапы акебой постоянно делаю- вчера раз 20 восстанавливалась: по умолчанию шаблон helix3, но на одной странице протостар и при входе/выходе в систему стили в одну кучу. Перенаправление уже указала на страницу протостар, а выкидывает все-равно на главную., т.е пункт меню подсвечивает "главная", а страница остается протостар и все стили вкучу- жалкое зрелище. При авторизации через Кунена- все в порядке, остаешься на месте.. но в кунене с бутстрапом качели. Все- таки у меня того, мозгов маловато :) :) :)

Авторизация

Войти через соцсети: