Inter-Net.PRO

Переустановить форум Kunena

  • 29 3
12 дек 2017 22:52 - 12 дек 2017 23:01 #1 от Алексей Е
Добрый день. Установил форум и с самого начала не заметил, что он как-то некорректно установился. А теперь уже есть несколько человек, которые там сидят и ещё ежедневно форум читают около сотни пользователей. Он конечно работает, но корявенько.
Дизайн ставил "из коробки" - Голубой Орёл. Уже несколько раз его ставил. Не было проблем. А тут...
Смайлы отказываются выстраиваться в шеренгу и нормально встраиваться в текст, со значками тем та же самая беда. Пока совсем отключил их.
Файлы также не загружаются на форум, ни картинки, ни архивы, ни документы. Не то чтобы это было так необходимо, но хотелось бы пользоваться всем функционалом.
Пришла идея его переустановить. Хочу спросить. Не пропадут ли при переустановке темы? Если пропадут, есть может быть какой-нибудь способ их сохранить.
Заранее спасибо за ответ.

С уважением.

  • 203 50
13 дек 2017 01:54 - 13 дек 2017 14:42 #2 от Inter-Net PRO

Установил форум

Я надеюсь кунена 5 или всё же 4?

работает, но корявенько

У вас видно что со стилями проблема. Насколько я помню, то как пример форма авторизации должна выглядеть вот так: Это или вы уже исправили, или конфликт со стилями шаблона. Хотя я склонен к первому варианту. Так же наверно и со смайликами.

Добавьте в css шаблона такой код:
#Kunena input {
    display: inline-block;
}
Тогда форма авторизации выровняется как на скрине.

Файлы также не загружаются на форум, ни картинки, ни архивы, ни документы.

Проверьте настройки - возможно в настройках запрещено. Так же может быть ограничение по весу файла, а вы загружаете превышающий лимит. Увеличьте в настройках лимит. Я смотрю картинки на форуме уже есть.

Пришла идея его переустановить. Хочу спросить. Не пропадут ли при переустановке темы? Если пропадут, есть может быть какой-нибудь способ их сохранить.

В таких случаях нужно пробовать на тестовом сайте - делать копию и ставить её на поддомен, а там уже экспереминтировать.
Так же на нормальном хостинге должен быть инструмент "Резервное копирование", который выручает если допустили глобальный косяк. Тогда можно откатить сайт и базу данных до какой то любой даты.

А так по идее можно новую кунену поверх ставить. Но это по идее, я давно уже такое не проверял.
Вложения:
Спасибо сказали: Алексей Е

  • 29 3
13 дек 2017 10:23 #3 от Алексей Е

Я надеюсь кунена 5 или всё же 4?


Версия: 4.0.12
Может в этом всё дело? Нужно его просто обновить?

Я смотрю картинки на форуме уже есть.


Это прописано BB-кодами. Т.е. грузили не через прикрепить из форума, а заливали сначала на сайт, потом прописывали путь.

Добавьте в css шаблона такой код:

#Kunena input {
display: inline-block;
}

Спасибищеогромнище! Сейчас попробую.

В таких случаях нужно пробовать на тестовом сайте - делать копию и ставить её на поддомен, а там уже экспереминтировать.

Это да. Мы на "опен сервер x64" делали сайт сначала. Так и остался тестовый сайт лежать там. На нём Kunena нормально работала. Вообще без проблем.

Так же на нормальном хостинге должен быть инструмент "Резервное копирование", который выручает если допустили глобальный косяк. Тогда можно откатить сайт и базу данных до какой то любой даты.

А так по идее можно новую кунену поверх ставить. Но это по идее, я давно уже такое не проверял

Есть резервное копирование. Переустановку оставлю на крайний случай. Сейчас попробую код поправить.

Большое спасибо за ответы.

P,S,
Кстати, форум получился отличный :)

С уважением.

  • 203 50
13 дек 2017 13:58 #4 от Inter-Net PRO

Версия: 4.0.12
Может в этом всё дело? Нужно его просто обновить?

Я бы советовал пятёрку. Всё таки всё движется вперёд. Джумла уже просит php 7, а когда выйдет Joomla 4 - у неё это будет обязательным требованием.
А ещё скоро выйдет Кунена 5.1, а там уже визуальный редактор, аудио-плеер и ряд полезных дополнений.

Правда в Кунена 5 нет шаблона Blue Eagle и это может принести огромную проблему. Точнее он есть, но на платной основе.

Спасибищеогромнище! Сейчас попробую.

Код лучше вставлять в css файл шаблона сайта. Если шаблон не обновляется (чтобы файл не перезаписался при обноалении). то можно в основной файл стилей. Если в шаблоне сайта есть файл custom.css - то в него.

Что касается вложений - посмотрите настройки
Кунена - Конфигурация - вкладка Изображения
Там есть настройки, чтобы разрешить вложения для изображений:
и чуть ниже для файлов:
И ограничения в размере изображений и файлов проверьте, чтобы необходимый размер пропускало
Вложения:
Спасибо сказали: Алексей Е

  • 29 3
13 дек 2017 23:26 #5 от Алексей Е
Решилась проблема с формой входа. Остальное без изменений :unsure:

С уважением.

  • 203 50
13 дек 2017 23:50 - 14 дек 2017 14:00 #6 от Inter-Net PRO

Алексей Е пишет: Остальное без изменений

Если создадите обычного пользователя и скинете его данные, то могу посмотреть как смайлики исправить.

А вот без вложений хреново. Может где на хостинге стоит запрет? Попробуйте написать в техподдержку хостинга и узнать есть ли настойка на запрет добавления файлов обычными пользователями на сайте и где такую настройку посмотреть.
Спасибо сказали: Алексей Е

  • 29 3
14 дек 2017 08:32 - 14 дек 2017 08:33 #7 от Алексей Е
Спасибо. Учётная запись с первым логином и паролем создана и активирована.

С уважением.

  • 203 50
14 дек 2017 14:17 #8 от Inter-Net PRO
Добавьте туда же куда для формы добавляли, вот этот код:
.kpostbuttons #smilie .btnImage {
    display: inline-block;
}
Смайлы станут горизонтально в ряд:
Вложения:
Спасибо сказали: Алексей Е

  • 203 50
14 дек 2017 14:52 - 14 дек 2017 16:51 #9 от Inter-Net PRO
А вот с вложениями - хостинг ни при чём.
Я создал тестовую тему, где вставил маленькое по весу изображение.

После сохранения темы - код страницы в том месте где вложение в посту: Подсвеченная синим цветом линия - это вложение в посту. Оно есть, но у него почему то формат .html

Когда я создавал пост, то при наведении на поле вложения есть подсказка разрешённых для загрузки файлов. Почему то в подсказке пишет два раза форматы изображений (я красным подчеркнул):


Проверьте настройки Разрешённые типы изображений и Разрешённые типы файлов - я в четвёртом посту вставлял скрины.
Мне кажется что вы в Разрешённые типы файлов добавили форматы изображений - jpg, jpeg, gif, png
Вложения:
Спасибо сказали: Алексей Е

  • 203 50
14 дек 2017 15:03 #10 от Inter-Net PRO
Тестовую тему что я создал - удалите, пользователя можете тоже удалить или отредактировать данные.
Спасибо сказали: Алексей Е

  • 29 3
14 дек 2017 15:43 #11 от Алексей Е
Понял удаляю

С уважением.

  • 29 3
14 дек 2017 17:20 #12 от Алексей Е

Inter-Net PRO пишет: Добавьте туда же куда для формы добавляли, вот этот код:

.kpostbuttons #smilie .btnImage {
    display: inline-block;
}
Смайлы станут горизонтально в ряд:


Всё получилось. Спасибо большое :)

С уважением.

  • 203 50
14 дек 2017 17:44 #13 от Inter-Net PRO

Всё получилось.

И с вложениями?

  • 29 3
14 дек 2017 18:16 - 14 дек 2017 18:19 #14 от Алексей Е
За вложения пока не садился из-за недостатка времени, так что, пока перенёс задачу на завтра. Ещё не смотрел. Всё напишу о своих экспериментах. И об успешных и о неудачных. Но мне кажется, я там сам что-то не то выставил в настройках конфигурации форума. :blush: Ещё раз спасибо за помощь, за толковые советы, за сайт и за форум на котором можно задать вопрос и получить спокойный взрослый ответ, а не плевки фекальной субстанцией в свой адрес. :) Неизвестно, сколько бы я сам ковырялся.

С уважением.

  • 29 3
24 июль 2018 23:10 - 25 июль 2018 20:37 #15 от Алексей Е
Занимался сегодня форумом. Столкнулся снова с проблемой невозможности загрузить файлы и изображения. В общем, всё сделал по инструкции. Не работает.

С уважением.
Вложения:

  • 203 50
25 июль 2018 20:36 - 25 июль 2018 20:40 #16 от Inter-Net PRO

Алексей Е пишет: Столкнулся снова с проблемой невозможности загрузить файлы и изображения. В общем, всё сделал по инструкции. Не работает.

Посмотрите в админке сайта Компоненты → Kunena → Конфигурация.
Там есть вкладка Изображения, а в ней пункт Макс. размер файла изображения (есть отдельно настройка для размера файлов, а есть ещё ниже для изображений).
Увеличьте значение максимального размера для изображений в этом пункте. Должно заработать.

ИЛИ
уменьшите размер и вес изображения, чтобы оно было меньше разрешённого в конфигурации. 
Спасибо сказали: Алексей Е

  • 29 3
26 июль 2018 10:50 - 26 июль 2018 10:58 #17 от Алексей Е
Эту настройку не убирал. До обновления оно все работало. Версия третья, кажется была. Потом обновились и стало все печально. 


На моей памяти с форумами Kunena всегда все было - ок. Проблемы начались с новых версий(сперва четвёртая, текущая версия форума 5.0.13), то с Гантри плагином были. Решил их. То вот теперь с загрузкой. 
Я наверное отключу просто возможность загружать на форум всякое.

С уважением.
Вложения:

  • 203 50
26 июль 2018 11:55 #18 от Inter-Net PRO
Да, такая настройка аж запредельно. Если ресурсы хостинга не безграничны - нужно уменьшить. Думаю это тестово включили чтоб уж наверняка в размер влезть.
А сайт с которым проблемы локально стоит (на компе) или в сети?

Я просмотрел куненовские сайт и гитхаб на запросы о подобных проблемах.

На оф сайте ТРИ темы есть с подобным, но они увы без каких либо решений:
www.kunena.org/forum/general-questions-a...ts-since-last-update  
www.kunena.org/forum/k5-1-support/153332...-of-the-allowed-size
www.kunena.org/forum/k5-1-support/151420...wed-by-configuration

На гитхабе только одна тема и то не знаю можно ли её как то сюда привязать:
github.com/Kunena/Kunena-Forum/issues/6039
Спасибо сказали: Алексей Е

  • 203 50
26 июль 2018 11:59 #19 от Inter-Net PRO
А вы пробовали какое нибудь маленькое изображение загрузить, чтоб весом вообще в пару килобайт?
Интересно пропустит картинку малого веса на загрузку или тоже блоканёт.
Спасибо сказали: Алексей Е

  • 29 3
02 авг 2018 19:19 #20 от Алексей Е
Хостинг не безграничен, но я со старых времен ещё оплатил. Так что не критично, еще на несколько лет. Вообще, настройками ограниченно до 4 гб. Но по факту никогда столько не было нужно. Максимум что я грузил полтора гига видео файл и то, ради теста, еще на джумле 2,5 и на другом форуме. 

Сайт стоит в выделенной джумловской среде не хостинге.

С маленькими изображениями и файлами я пробовал. Их блочиит. Но так чтобы совсем маленькие не пробовал. Я думал на хостинге не обновлён был пхп, из-за этого. Но сейчас там все обновили и все равно проблемы.

Попробую, напишу что получится. Но я на "Охране Труда" уже все отключил. Кстати, всё спросить хотел, у Вас же на этом стоит модуль дискуссий родной куненовский? 

С уважением.

Авторизация

Войти через соцсети: